Registration not working

Incident Report for Confidence Systems

Resolved

This incident has been resolved.
Posted Nov 21, 2020 - 20:33 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 21, 2020 - 20:32 UTC